<!DOCTYPE html>
<!--[if IE 7]>
<html class="ie ie7" lang="en-US">
<![endif]-->
<!--[if IE 8]>
<html class="ie ie8" lang="en-US">
<![endif]-->
<!--[if !(IE 7) | !(IE 8)  ]><!-->
<html lang="en-US">
<!--<![endif]-->
<head>
	<meta charset="UTF-8">
	<meta name="viewport" content="width=device-width">
	<title>Sterling notes: NFL week 8 | The Drive</title>
	<link rel="profile" href="http://gmpg.org/xfn/11">
	<link rel="pingback" href="https://thedrive.bangordailynews.com/xmlrpc.php">
	<!--[if lt IE 9]>
	<script src="https://thedrive.bangordailynews.com/wp-content/themes/bdnblog2013/js/html5.js"></script>
	<![endif]-->
	<link rel='dns-prefetch' href='//thedrive.bangordailynews.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//secure.gravatar.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//cdnjs.cloudflare.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//bdn-data.s3.amazonaws.com' />
<link rel="alternate" type="application/rss+xml" title="The Drive &raquo; Feed" href="https://thedrive.bangordailynews.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Drive &raquo; Comments Feed" href="https://thedrive.bangordailynews.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Drive &raquo; Sterling notes: NFL week 8 Comments Feed" href="https://thedrive.bangordailynews.com/2018/10/28/sports/sterling-notes-nfl-week-8/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.4\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.4\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/thedrive.bangordailynews.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.9.6"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55357,56692,8205,9792,65039],[55357,56692,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='contact-form-7-css'  href='https://thedrive.bangordailynews.com/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=4.7' type='text/css' media='all' />
<link rel='stylesheet' id='wp-email-css'  href='https://thedrive.bangordailynews.com/wp-content/plugins/wp-email/email-css.css?ver=2.67.5' type='text/css' media='all' />
<link rel='stylesheet' id='bdnblog2013-fonts-css'  href='http://fonts.googleapis.com/css?family=Open+Sans:300,400,700,300italic,400italic,700italic|Roboto+Slab:400italic,700italic,400,700' type='text/css' media='all' />
<link rel='stylesheet' id='genericons-css'  href='https://thedrive.bangordailynews.com/wp-content/plugins/jetpack/_inc/genericons/genericons/genericons.css?ver=3.1' type='text/css' media='all' />
<link rel='stylesheet' id='bdnblog2013-style-css'  href='https://thedrive.bangordailynews.com/wp-content/themes/bdnblog2013/style.css?ver=2016-10-24' type='text/css' media='all' />
<link rel='stylesheet' id='fontawesome-css'  href='https://cdnjs.cloudflare.com/ajax/libs/font-awesome/4.3.0/css/font-awesome.css?ver=4.9.6' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://thedrive.bangordailynews.com/wp-content/plugins/jetpack/css/jetpack.css?ver=5.9' type='text/css' media='all' />
<script type='text/javascript' src='https://thedrive.bangordailynews.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='https://thedrive.bangordailynews.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='https://thedrive.bangordailynews.com/wp-content/plugins/bdn-plugins/js/audience.js?ver=14'></script>
<script type='text/javascript' src='https://thedrive.bangordailynews.com/wp-content/plugins/bdn-plugins/js/jwplayer-listener.js?ver=20170410.1'></script>
<script type='text/javascript' src='https://thedrive.bangordailynews.com/wp-content/plugins/bdn-plugins/js/youtube-listener.js?ver=20170410.1'></script>
<link rel='https://api.w.org/' href='https://thedrive.bangordailynews.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://thedrive.bangordailynews.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://thedrive.bangordailynews.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Drive Audio: Pete Abraham gives Sox World Series preview' href='https://thedrive.bangordailynews.com/2018/10/22/sports/drive-audio-pete-abraham-gives-sox-world-series-preview/' />
<meta name="generator" content="WordPress 4.9.6" />
<link rel="canonical" href="https://thedrive.bangordailynews.com/2018/10/28/sports/sterling-notes-nfl-week-8/" />
<link rel='shortlink' href='https://wp.me/p5DUdu-BW' />
<link rel="alternate" type="application/json+oembed" href="https://thedrive.bangordailynews.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fthedrive.bangordailynews.com%2F2018%2F10%2F28%2Fsports%2Fsterling-notes-nfl-week-8%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://thedrive.bangordailynews.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fthedrive.bangordailynews.com%2F2018%2F10%2F28%2Fsports%2Fsterling-notes-nfl-week-8%2F&#038;format=xml" />

<link rel='dns-prefetch' href='//v0.wordpress.com'/>
<style type='text/css'>img#wpstats{display:none}</style>	 <div id="fb-root"></div>
	 <script>(function(d, s, id) {
			 var js, fjs = d.getElementsByTagName(s)[0];
			 if (d.getElementById(id)) return;
			 js = d.createElement(s); js.id = id;
			 js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.6&appId=748756371893770";
			 fjs.parentNode.insertBefore(js, fjs);
		 }(document, 'script', 'facebook-jssdk'));</script>
            
	<script type="text/javascript" src="//s7.addthis.com/js/300/addthis_widget.js#pubid=ra-51c20b68617564b1" data-minify="no" ></script>
	<script type="text/javascript">	    
        var addthis_config = {
            data_ga_tracker:'UA-5329647-48',
            data_track_addressbar:false
	    }; 
	    var addthis_share = {
            url: 'https://wp.me/p5DUdu-BW',
            title: 'Sterling notes: NFL week 8',
            templates: {
                twitter: '{{title}}: {{url}} (via @bangordailynews)',
            }
	    };
        
        addthis.layers({
            'theme' : 'transparent',
                'share' : {
                  'position' : 'left',
                  'numPreferredServices' : 4,
                  'services' : "facebook,twitter,pinterest,email,more",
                'postShareFollowMsg' : "Follow The Drive:",
                  'offset' : {'top' : '320px'}
                }, 
            'follow' : {
              'services' : [
            {'service': 'facebook', 'id': 'bangordailynews'},
            {'service': 'twitter', 'id': 'bangordailynews'},
            {'service': 'rss', 'id': 'https://thedrive.bangordailynews.com/feed/'}
              ],
              'offset' : {'top': '30px'}
            },  
            'whatsnext' : {} 
	  });
	  

	</script>
	<!-- AddThis Smart Layers END -->
    
    <!-- Please call pinit.js only once per page -->
    <!--I'm putting this here so it's only called once-->
    <script type="text/javascript" async src="//assets.pinterest.com/js/pinit.js"></script>
    
    
    <script type="text/javascript">
        var googletag = googletag || {}; googletag.cmd = googletag.cmd || [];
        (function () {
	        var gads = document.createElement("script");
	        gads.async = true;
	        gads.type = "text/javascript";
	        var useSSL = "https:" == document.location.protocol;
	        gads.src = (useSSL ? "https:" : "http:") + "//www.googletagservices.com/tag/js/gpt.js";
	        var node = document.getElementsByTagName("script")[0];
	        node.parentNode.insertBefore(gads, node);
        })();
        </script>
                <script type="text/javascript">
        googletag.cmd.push(function() {
            var pid_value = "sterling-notes-nfl-week-8";
	    googletag.defineSlot('/21682974628/bangordailynews', [[300,250], [300,600]], "bdnads-blogs-top-300x250")
			.addService(googletag.pubads())
			.setTargeting("pos", "top");
	    googletag.defineSlot('/21682974628/bangordailynews', [300,250], "bdnads-blogs-bottom-300x250")
			.addService(googletag.pubads())
			.setTargeting("pos", "bottom");
        googletag.defineSlot('/21682974628/bangordailynews', [[970,250], [970,90]], "bdnads-blogs-top-leaderboard")
            .addService(googletag.pubads())
            .setTargeting("pos", "top");

                            googletag.defineSlot('/21682974628/bangordailynews', [300,50], "bdnads-blogs-mobile-300x50")
	            .addService(googletag.pubads())
                .setTargeting("pos", "mobile");
	        googletag.defineSlot('/21682974628/bangordailynews', [[300,250]], "bdnads-inline-300x250")
		        .addService(googletag.pubads())
		        .setTargeting("pos", "inline");

        
							googletag.pubads().setTargeting( 'author', 'blog' );
			            googletag.pubads().setTargeting("pid", pid_value);
                        googletag.pubads().setTargeting("kw", ['The Drive', 'sports', 'blog']);
            googletag.pubads().enableSingleRequest();           
            googletag.pubads().collapseEmptyDivs();
            googletag.enableServices();
	});
	</script>
    	<style type="text/css" id="bdnblog2013-header-css">
			.site-header {
			background: url(https://bdn-data.s3.amazonaws.com/blogs.dir/283/files/2015/01/cropped-the-drive-header.png) no-repeat scroll top;
			background-size: 1600px auto;
		}
			.site-title,
		.site-description {
			position: absolute;
			clip: rect(1px 1px 1px 1px); /* IE7 */
			clip: rect(1px, 1px, 1px, 1px);
		}
		</style>
	
<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="Sterling notes: NFL week 8" />
<meta property="og:url" content="https://thedrive.bangordailynews.com/2018/10/28/sports/sterling-notes-nfl-week-8/" />
<meta property="og:description" content="This is how the Patriots will get Tua Tagovailoa and continue the dynasty another 15 years." />
<meta property="article:published_time" content="2018-10-28T09:29:00+00:00" />
<meta property="article:modified_time" content="2018-10-27T20:31:29+00:00" />
<meta property="og:site_name" content="The Drive" />
<meta property="og:image" content="https://bdn-data.s3.amazonaws.com/blogs.dir/283/files/2015/01/the-drive-square-logo.png" />
<meta property="og:image:width" content="900" />
<meta property="og:image:height" content="900" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:text:title" content="Sterling notes: NFL week 8" />
<meta name="twitter:image" content="https://bdn-data.s3.amazonaws.com/blogs.dir/283/files/2015/01/the-drive-square-logo.png?w=640" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:site" content="@bdnmaineblogs" />

    <script>
        (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
        (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
        m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
        })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

        ga('create', 'UA-5329647-1', 'auto');        ga('require', 'linkid', 'linkid.js');
        ga('require', 'displayfeatures');
        ga('send', 'pageview', {
            'dimension1': 'Sterling Pingree','dimension2': 'post','dimension3': '283.2352','dimension5': 'sports',				'dimension10': '0',
				 
				'dimension11' : 'New England Patriots,NFL Week 8'

				        }); //ga send

        /**
         * UA-5329647-52 is the id for the new rollup property
         * It is normally only used in the GTM container. It needs to be added here to be able to send video events
         * direct to the property because the current GTM container is not included on mobile.
         */
        ga('create', 'UA-5329647-52', 'auto', 'rollup4video');
    </script>

			<script>

		/**
		* Function that tracks a click on an outbound link in Google Analytics.
		* This function takes a valid URL string as an argument, and uses that URL string
		* as the event label. Setting the transport method to 'beacon' lets the hit be sent
		* using 'navigator.sendBeacon' in browser that support it.
		 * 
		 * @see https://support.google.com/analytics/answer/1136920?hl=en
		*/
		jQuery(function() {
			jQuery('.entry p a').on( 'click', function() {
				ga('send', 'event', 'in-article click', '283.2352', jQuery(this).attr('href'), {
				  'transport': 'beacon'
				});
			});
		});

		
		jQuery(function($) {
		    // Default time delay before checking location
		    var callBackTime = 100;

		    // # px before tracking a reader
		    var readerLocation = 150;

		    // Set some flags for tracking & execution
		    var timer = 0;
		    var scroller = false;
		    var endContent = false;
		    var didComplete = false;

		    // Set some time variables to calculate reading time
		    var startTime = new Date();
		    var beginning = startTime.getTime();
		    var totalTime = 0;

		    // Get some information about the current page
		    var pageTitle = '283.2352';

		    // Track the aticle load
	        ga('send', 'event', 'Reading', 'ArticleLoaded', pageTitle, {'nonInteraction': 1});


		    // Check the location and track user
		    function trackLocation() {
		        bottom = jQuery(window).height() + jQuery(window).scrollTop();
		        height = jQuery(document).height();

		        // If user starts to scroll send an event
		        if (bottom > readerLocation && !scroller) {
		            currentTime = new Date();
		            scrollStart = currentTime.getTime();
		            timeToScroll = Math.round((scrollStart - beginning) / 1000);

		            ga('send', 'event', 'Reading', 'StartReading', pageTitle, timeToScroll);
		            scroller = true;
		        }

		        // If user has hit the bottom of the content send an event
		        if (bottom >= jQuery('.entry').offset().top + jQuery('.entry').innerHeight() && !endContent) {
		            currentTime = new Date();
		            contentScrollEnd = currentTime.getTime();
		            timeToContentEnd = Math.round((contentScrollEnd - scrollStart) / 1000);
		            ga('send', 'event', 'Reading', 'ContentBottom', pageTitle, timeToContentEnd);
		            endContent = true;
		        }

		        // If user has hit the bottom of page send an event
		        if (bottom >= height && !didComplete) {
		            currentTime = new Date();
		            end = currentTime.getTime();
		            totalTime = Math.round((end - scrollStart) / 1000);

	                if (totalTime < 60) {
	                	ga('set', 'dimension8', 'Scanner');
	                } else {
	                	ga('set', 'dimension8', 'Reader');
	                }

	                ga('send', 'event', 'Reading', 'PageBottom', pageTitle, totalTime);
		            didComplete = true;
		        }
		    }

		    // Track the scrolling and track location
		    jQuery(window).scroll(function() {
		        if (timer) {
		            clearTimeout(timer);
		        }

		        // Use a buffer so we don't call trackLocation too often.
		        timer = setTimeout(trackLocation, callBackTime);
		    });


		});

		</script>

	

	<script type="text/javascript">
	var BdnAdsCommandArray = new Array();
	</script>
</head>

<body class="post-template-default single single-post postid-2352 single-format-standard sidebar">


		<script type="text/javascript">
	(function() {
	  var ARTICLE_URL = window.location.href;
	  var CONTENT_ID = 'everything';
	  document.write(
	    '<scr'+'ipt '+
	    'src="//survey.g.doubleclick.net/survey?site=_co4sl7ki43vcs'+
	    '&amp;url='+encodeURIComponent(ARTICLE_URL)+
	    (CONTENT_ID ? '&amp;cid='+encodeURIComponent(CONTENT_ID) : '')+
	    '&amp;random='+(new Date).getTime()+
	    '" type="text/javascript">'+'\x3C/scr'+'ipt>');
	})();
	</script>
    

	<div id="page" class="hfeed site">
		<header id="masthead" class="site-header" role="banner">
            <div class="home-link">
				<a href="https://thedrive.bangordailynews.com/" title="The Drive" rel="home">
					<h1 class="site-title">The Drive</h1>
                    <h2 class="site-description">Your sports. Your teams. Your show.</h2>
				</a>
                <a class="bdn-link" href="http://bangordailynews.com/maine-blogs/?utm_source=The+Drive&utm_medium=footer">
	                <!--                    <img src="-->
	                <!--/images/BDN_Square.jpg" width="32" alt="BDN Maine" title="BDN Maine"/>-->
	                <!--                    Blog-->
	                <img src="https://thedrive.bangordailynews.com/wp-content/themes/bdnblog2013/images/bdn_blogs_logo.jpg" alt="BDN Maine"
	                     title="BDN Maine"/>
                </a>
            </div>
			<div id="navbar" class="navbar">
				<nav id="site-navigation" class="navigation main-navigation" role="navigation">
					<h3 class="menu-toggle">Menu</h3>
					<a class="screen-reader-text skip-link" href="#content" title="Skip to content">Skip to content</a>
					<div class="menu-menu-1-container"><ul id="menu-menu-1" class="nav-menu"><li id="menu-item-12" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-12"><a href="http://thedrive.bangordailynews.com/">Home</a></li>
<li id="menu-item-13" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-13"><a href="https://thedrive.bangordailynews.com/contact-us/">Contact Us</a></li>
<li id="menu-item-673" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-673"><a href="https://thedrive.bangordailynews.com/about/">ABOUT</a></li>
</ul></div>					<form role="search" method="get" id="searchform" class="search-form" action="https://thedrive.bangordailynews.com">
	<label>
		<span class="screen-reader-text" for="s">Search for:</span>
		<input type="search" class="search-field" value="" name="s" placeholder="Search ..." title="Search for:">
	</label>
	<input type="submit" class="search-submit" id="searchsubmit" value="Search">
</form>				</nav><!-- #site-navigation -->
			</div><!-- #navbar -->
		</header><!-- #masthead -->

                <div class="adSpot widget">
            <div id="bdnads-blogs-oop-interstitial">
                <script type="text/javascript">
                    googletag.cmd.push(function () {
                        googletag.display("bdnads-blogs-oop-interstitial");
                    });
                </script>
            </div>
        </div>
                            <div class="adSpot widget">
                                    <div id="bdnads-blogs-top-leaderboard">
                        <script type="text/javascript">
                            googletag.cmd.push(function () {
                                googletag.display("bdnads-blogs-top-leaderboard");
                            });
                        </script>
                    </div>
                            </div>
            <div id="main" class="site-main">

	<div id="primary" class="content-area">
		<div id="content" class="site-content" role="main">

						
				<article id="post-2352" class="post-2352 post type-post status-publish format-standard has-post-thumbnail hentry category-home category-sports tag-new-england-patriots tag-nfl-week-8">
	<header class="entry-header">
		
            <h1 class="entry-title">Sterling notes: NFL week 8</h1>

		
		<div class="entry-meta">
			<span class="date"><a href="https://thedrive.bangordailynews.com/2018/10/28/sports/sterling-notes-nfl-week-8/" title="Permalink to Sterling notes: NFL week 8" rel="bookmark"><time class="entry-date" datetime="2018-10-28T05:29:00+00:00">October 28, 2018</time></a></span><span class="categories-links"><a href="https://thedrive.bangordailynews.com/category/home/" rel="category tag">Home</a>, <a href="https://thedrive.bangordailynews.com/category/sports/" rel="category tag">Sports</a></span><span class="tags-links"><a href="https://thedrive.bangordailynews.com/tag/new-england-patriots/" rel="tag">New England Patriots</a>, <a href="https://thedrive.bangordailynews.com/tag/nfl-week-8/" rel="tag">NFL Week 8</a></span>					    <div class="author-byline">
			By <a href="https://thedrive.bangordailynews.com/author/spingree/" title="Posts by Sterling Pingree" rel="author">Sterling Pingree</a>		    </div><!-- /.author-byline -->
		</div><!-- .entry-meta -->
	</header><!-- .entry-header -->

	
	<div class="entry-content entry">

        
    
    <!-- AddThis Button BEGIN -->
    <div class="addthis_toolbox addthis_default_style">
        
        <!-- Facebook button -->
        <div class='share-button'>
            <div class="fb-like" data-href="https://thedrive.bangordailynews.com/2018/10/28/sports/sterling-notes-nfl-week-8/" data-layout="button_count" data-action="like" data-show-faces="false" data-share="false"></div>
        </div>

        <!-- Tweet button -->
        <div class='share-button'>
            <a href="https://twitter.com/share" 
               class="twitter-share-button" 
               data-text="Sterling notes: NFL week 8."
               data-url="https://thedrive.bangordailynews.com/2018/10/28/sports/sterling-notes-nfl-week-8/"
               data-via='bdnmaineblogs'               data-related=",bdnmaineblogs,bangordailynews"
               data-lang="en">Tweet</a>
            <script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0];if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src="https://platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");</script>
        </div>


        <!-- Pin it button -->
        <div class='share-button'>
        <a href="//www.pinterest.com/pin/create/button/?url=https://thedrive.bangordailynews.com/2018/10/28/sports/sterling-notes-nfl-week-8/&media=https://bdn-data.s3.amazonaws.com/blogs.dir/283/files/2015/01/the-drive-square-logo-250x250.png&description=Sterling notes: NFL week 8" data-pin-do="buttonPin" data-pin-config="none">
            <img src="//assets.pinterest.com/images/pidgets/pinit_fg_en_rect_gray_20.png" />
        </a>
        </div>
        
        <div class='share-button'>
            <a class="addthis_counter addthis_pill_style"></a>
        </div>
    </div>
    <!-- AddThis Button END -->


		<div class="p402_premium">
			<p>By Sterling Pingree</p>
<p>Philadelphia at Jacksonville (In London)</p>
<p>Blake Bortles was benched last week for Cody Kessler. Cody freakin Kessler. Jags head coach Doug Marrone came out this week and said that Bortles is his guy and why did he do this? Because Blake Bortles is great in London. I’m pretty sure he was knighted right after Paul McCartney and before Patrick Stewart. It’s inexplicable, but imagine you’re a fan in London and the team you annually see is the Jacksonville Jaguars, with the way the Jags play in England, they probably imagine that they’re an NFL dynasty and Blake Bortles is Joe Montana. It’s like your cousin at Thanksgiving who only watches football on that one day and assumes that Dallas hasn’t slowed down since the Jimmy Johnson days and that they’re still America’s team. Perception is such a weird thing. Please watch more football England. Sorry for sending the Raiders.</p>
<p>Denver at Kansas City</p>
<p>Is anybody but the Patriots going to slow down the Chiefs? Mahomes is making crazy throws across his body every week, Tyreek Hill is a scumbag and also the fastest player I’ve ever seen on the football field. It’s disgusting, but he is. I’m really interested in this game, because the Broncos defense was able to throw speed bumps in front of the Chiefs offense at Mile High, but can they do it on the road? Probably not, but Von Miller had his ears pinned back last week at Arizona and if they stay pinned (is that a thing?) this week, he could disrupt Andy Reid’s air show. Disrupt, not stop, because the frustrating thing about trying to get off the field against the Chiefs is how improvisational it is when plays break down. They’re the school yard team where all the 8<sup>th</sup> graders join forces and hold court against the rest of the school.</p>
<p>Cleveland at Pittsburgh</p>
<p>Talk about a rivalry. Week 1, these two teams tied 21-21 and now the AFC North seems to have to been righted: the Browns have dropped a couple straight, the Steelers beat the Bengals again and appear ready to take hold of the division. What is Le’Veon Bell doing? Is he going to come back in week 10? Will that help Pittsburgh? It’s not getting as much attention because the team has won a couple in a row, but that doesn’t mean that the Steeler’s problems have vanished.</p>
<p>Washington at NY Giants</p>
<p>Washington is playing like an Alex Smith team and one of the things that an Alex Smith team does is win games against teams like the Giants. The Giants took their shot last Monday against Atlanta and came up short against a ghastly defense. The Redskins don’t do any one thing at an elite level, but they’re steady in all areas. In a volatile NFC East, that could be enough to win the division at 9-7.</p>
<p>Seattle at Detroit</p>
<p>Both teams are 3-3, but the Seahawks are a soft 3-3 beating up on the Raiders, Cardinals and Cowboys but actually their three losses are more impressive than their three wins. Their losses are 27-24 at Denver, 24-17 at Chicago and 33-31 at home vs the undefeated Rams. So why do I feel like the Seahawks are going to fall in Detroit? Because Detroit is the opposite, their wins are really impressive and their losses are disgusting. The Lions have beaten New England, Green Bay and Miami while losing to the Jets, Cowboys and 49ers. Huh? How does that make sense at all, but teams are 3-3 but they’re both the wrong 3-3. Kind of like how Mitchell Trubisky threw two interceptions last week against New England, but the two that he threw, weren’t the two that he deserved. Gilmore and Roberts dropped picks in the end zone, yet JC Jackson and Jonathan Jones made incredible plays to pick passes off. It all evens out eventually.</p>
<p>Tampa Bay at Cincinnati</p>
<p>The Bengals are doing what the Bengals do: get off to a hot start, lose to Pittsburgh and then try to sneak into a wild card spot. Oh and Vontaze Burfict has tried to maim people and is already injured after coming off of suspension. That’s essentially the proud tradition of the Cincinnati Bengals.</p>
<p>NY Jets at Chicago</p>
<p>Mitchell Trubisky is probably fun to watch. I say probably because last week against the Patriots he wasn’t fun to watch, he was frustrating in that Blake Bortles type of “he can’t really throw the ball accurately, but he can run just enough to pick up annoying third downs.” You know which quarterback I’d also put in this same category? Dak Prescott. Prescott, since his emergence in 2016 has regressed to this same style of quarterback. I’m not sure if this is the wave of the future, but I surely hope that it isn’t, though the games stay interesting when the QB slings it around like your uncle at the family picnic who brought an 18-pack for himself and was “second team all-district 1981”.</p>
<p>Baltimore at Carolina</p>
<p>One of the best defenses in the league against the Panthers. What can you say about the Panthers? That isn’t a rhetorical question, I really mean it: what is there to say about the Carolina Panthers? I think they’ll make the playoffs as a wild card, but I couldn’t begin to tell you what their betting line would be in the first round against any team.</p>
<p>Indianapolis at Oakland</p>
<p>The Raiders as a dumpster fire and getting worse. Kevin Clark this week on the Ringer NFL podcast compared Jon Gruden being in charge of personnel to John Mulaney’s joke about a horse being loose in a hospital. You don’t know what’s going to happen, but whatever it is you’re pretty sure it’s bad. Also, you’re checking Twitter every few minutes to see what the horse is doing in the hospital because it is such a curiosity. Gruden is the same way since he donned again the “Silver and Black”. Trade Khalil Mack? Sure. Question why your team doesn’t have a pass rush two weeks later, forgetting that you traded the best pass rusher in the league? Of course. Dealing Amari Cooper, that one was actually smart. I can’t believe the Cowboys gave up a 1<sup>st</sup> rounder for Amari freakin Cooper. (By the way, this is how the Patriots will eventually get the #1 pick in the draft two years from now and select Tom Brady’s replacement: Tua Tagovailoa. I told that idea to my buddy Earnest this week and he almost strangled me and hasn’t spoken to me since. Earnest isn’t a Patriots fan.)</p>
<p>San Francisco at Arizona</p>
<p>These teams just played and Arizona topped the 9ers in the post-Jimmy era. Since that game however, CJ Beathard almost beat the Packers on Monday night and the Cardinals gave the ugliest performance in the history of the NFL. (Don’t look that up.) Josh Rosen couldn’t hang onto the football, and when he did get passes off, he was leading Broncos corners like they were the ones running routes. I’ve never seen anything like it.</p>
<p>Green Bay at LA Rams</p>
<p>The biggest point spread that Aaron Rodgers has ever faced is this week at Los Angeles. The Packers defense is one of the worst in the league and against Sean McVey’s offense, this one really could get out of hand. What a stretch this is for the Packers: at LA this week, at New England for Sunday Night Football next week, then it is home for Miami and then at Seattle and then at Minnesota. We’ll learn a lot about the Packers in the next 5 weeks. The NFC North is the most interesting division in the NFL, you could convince me that any of these four teams could win the division and that they could finish last.</p>
<p>New Orleans at Minnesota</p>
<p>Back to the scene of the crime for New Orleans and the Saints look like the second best team in the NFC but much like last year, the Vikings will have something to about that. On paper, the Vikings should be better than last year’s team and at times have played like it, consistency has been their biggest issue, plus that loss to Buffalo at home might as well be a scarlet letter on their purple uniforms.</p>
<p>New England at Buffalo</p>
<p>I’ll be honest, before the season, I was nervous about this game. On the road, at Buffalo on a Monday night, you know the Bills Mafia is going to start their tailgates on Saturday and the Patriots pilgrimage to Orchard Park might as well be called the Buffalo Super Bowl. The Bills haven’t played a Monday nighter at home since 2008, these are rare occasions. But I don’t know what’s happened to the Bills, maybe I was just more nervous about the AJ McCarron signing or maybe I was nervous about what Sean McDermott was building there but I thought this was for certain the weird prime time divisional game that the Patriots would lose. (Turns out that was likely the Detroit game in week 3.) Sony Michel and Gronk have practiced this week, not sure which is more surprising. I asked Christopher Price on Friday’s edition of The Drive who he thought would play first and he said Gronk, who has been dealing with back spasms. If I’m Bill Belichick, I sit both guys out this week and make sure that the offense is healthy for the next two games: home for Green Bay and at Tennessee week 10. I’m ready for a lot of Kenjon Barner and probably 12 catches from James White. The Bills offense has had the worst 7 games to start a season in NFL history, this is exactly the type of team that the Patriots D needs to face to try and get its mojo going as we turn out calendars to November.</p>
<p><strong><em><a href="https://bdn-data.s3.amazonaws.com/blogs.dir/283/files/2016/05/Sterling-Head-Shot.jpg"><img class=" wp-image-235 alignleft" src="https://bdn-data.s3.amazonaws.com/blogs.dir/283/files/2016/05/Sterling-Head-Shot-450x253.jpg" alt="" width="327" height="184" srcset="https://bdn-data.s3.amazonaws.com/blogs.dir/283/files/2016/05/Sterling-Head-Shot-450x253.jpg 450w, https://bdn-data.s3.amazonaws.com/blogs.dir/283/files/2016/05/Sterling-Head-Shot-600x337.jpg 600w" sizes="(max-width: 327px) 100vw, 327px" /></a>Sterling Pingree (@SterlingPingree on Twitter) is a co-host on The Drive, weekdays 4pm to 6pm on 92.9fm The Ticket and streaming live at DriveShowMaine.com. Follow us on Twitter, @DriveShowMaine and “Like Us” on Facebook, Drive Show Maine. </em></strong></p>

		</div>
			
			        <script type="text/javascript">
            try {
                _402_Show();
            } catch (e) {
            }
        </script>
	    
			
    
    <!-- AddThis Button BEGIN -->
    <div class="addthis_toolbox addthis_default_style">
        
        <!-- Facebook button -->
        <div class='share-button'>
            <div class="fb-like" data-href="https://thedrive.bangordailynews.com/2018/10/28/sports/sterling-notes-nfl-week-8/" data-layout="button_count" data-action="like" data-show-faces="false" data-share="false"></div>
        </div>

        <!-- Tweet button -->
        <div class='share-button'>
            <a href="https://twitter.com/share" 
               class="twitter-share-button" 
               data-text="Sterling notes: NFL week 8."
               data-url="https://thedrive.bangordailynews.com/2018/10/28/sports/sterling-notes-nfl-week-8/"
               data-via='bdnmaineblogs'               data-related=",bdnmaineblogs,bangordailynews"
               data-lang="en">Tweet</a>
            <script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0];if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src="https://platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");</script>
        </div>


        <!-- Pin it button -->
        <div class='share-button'>
        <a href="//www.pinterest.com/pin/create/button/?url=https://thedrive.bangordailynews.com/2018/10/28/sports/sterling-notes-nfl-week-8/&media=https://bdn-data.s3.amazonaws.com/blogs.dir/283/files/2015/01/the-drive-square-logo-250x250.png&description=Sterling notes: NFL week 8" data-pin-do="buttonPin" data-pin-config="none">
            <img src="//assets.pinterest.com/images/pidgets/pinit_fg_en_rect_gray_20.png" />
        </a>
        </div>
        
        <div class='share-button'>
            <a class="addthis_counter addthis_pill_style"></a>
        </div>
    </div>
    <!-- AddThis Button END -->


	</div><!-- .entry-content -->

	
	<footer class="entry-meta">
	    			</footer><!-- .entry-meta -->
</article><!-- #post -->
					<nav class="navigation post-navigation" role="navigation">
		<h1 class="screen-reader-text">Post navigation</h1>
		<div class="nav-links">

			<a href="https://thedrive.bangordailynews.com/2018/10/22/sports/drive-audio-pete-abraham-gives-sox-world-series-preview/" rel="prev"><span class="meta-nav">&larr;</span> Drive Audio: Pete Abraham gives Sox World Series preview</a>			
		</div><!-- .nav-links -->
	</nav><!-- .navigation -->
	   
		    
				<div class="OUTBRAIN entry-meta" data-src="https://thedrive.bangordailynews.com/2018/10/28/sports/sterling-notes-nfl-week-8/" data-widget-id="AR_1" data-ob-template="bangordaily" ></div>
				<script type="text/javascript" async="async" src="http://widgets.outbrain.com/outbrain.js"></script>

				
<div id="comments" class="comments-area comment-respond">
    <div class="comment-list">
            
            <div class="fb-comments" data-href="http://thedrive.bangordailynews.com/2018/10/28/sports/sterling-notes-nfl-week-8/" data-colorscheme="light" data-width="604"></div>
            
                        <script>
                jQuery(document).ready(function( $ ) {
                     FB.Event.subscribe('comment.create', function(response) {

                        //Send an email with ajax

                        $.ajax({
                            type: "GET",
                            url: "/wp-admin/admin-ajax.php?action=bdn_facebook_comment_notifications_send",
                            data: { 
                                post_author : "Sterlingpingree@hotmail.com", 
                                post_title : "Sterling notes: NFL week 8", 
                                post_link : "https://thedrive.bangordailynews.com/2018/10/28/sports/sterling-notes-nfl-week-8/", 
                                post_id : "2352"
                            }, 
                            dataType: "json",
                            beforeSend:  function() {
                                console.log('Sending message');
                            },
                            success: function(html){
                               console.log('Success sending email');
                               console.log(html);
                            },
                            error: function(html){
                                console.log('There was an error sending the notification email');
                                console.log(html)
                            }
                        });
                     });
                });
               
            </script>
                        
            
            
           
    </div>
</div><!-- #comments -->

			
		</div><!-- #content -->
	</div><!-- #primary -->


	
    <div id="tertiary" class="sidebar-container" role="complementary">
	<div class="sidebar-inner">
	    <div class="widget-area">

		<div class="adSpot widget" style="min-height:270px;">
		    <div id="bdnads-blogs-top-300x250">
		     <script type="text/javascript">
			  googletag.cmd.push(function() {
				googletag.display("bdnads-blogs-top-300x250");
			   });
		      </script>
		    </div>
		</div>

		<aside id="bdn_blog_bio-4" class="widget widget_bdn_blog_bio"><h3 class="widget-title">                <div class="widget blog-authors">
                    <h3>SportsNet Maine</h3>
                    <a class="author-avatar" href="">
                        <img src="http://gravatar.com/avatar/443a78653ca91424a57bc90c9e789076?s=80&d=https%3A%2F%2Fbdn-data.s3.amazonaws.com%2Fblogs.dir%2F283%2Ffiles%2F2015%2F01%2Fthe-drive-square-logo-300x300.png"
                             alt="SportsNet Maine"
                             title="SportsNet Maine"
                             class="gravatar avatar"
                             align="left"
                             width="80" 
                             height="80" 
                         />
                    </a>
                    <p>
                                            </p>
                    
                                        
                                        
                    
                </div>
                
        </h3></aside>        <div class="bdn-blogs-widget widget category-sports">
            <!--
            Document   : Formerly bdn-blog-promotions.css
            Created on : Sep 16, 2013, 4:43:03 PM
            Author     : Pattie Reaves
            Version	   : 1.1
            Description: Styles the BDN blogs widget.
             -->
            <style>
                .bdn-blog-headshot {
                    width: 70px;
                    height: 70px;
                    -moz-border-radius: 35px;
                    -webkit-border-radius: 35px;
                    border-radius: 35px;
                }

                .bdn-blogs-widget-posts img {
                    margin: 0 10px 10px 0;
                }

                .bdn-blogs-widget-posts {
                    border: #006743 solid 1px;
                    padding: 5px;
                }

                .bdn-blogs-widget-header {
                    overflow: auto;
                    background-color: #006743;
                    color: #fff;
                }

                .bdn-blogs-widget-header img {margin-right: 10px;}
                .bdn-blogs-widget-header h3 {font-size: 50px; clear: right; margin: 10px;}
                .widget .bdn-blogs-widget-header a, .widget .bdn-blogs-widget-header a:visited {color: #fff; line-height: 30px;}

                .blogwidget {
                    margin: 10px 0;
                    padding: 10px 0;
                    overflow: auto;
                    border-bottom: 1px solid #ddd;
                }

                .blogwidget:first-of-type {
                    margin-top: 0;
                }
                .blogwidget:last-of-type {
                    margin-bottom: 0;
                }

                .bdn-blogs-widget-header .promo-links {margin-left: 5px;}

                h4.blogstory, h5.blogname {
                    margin: 0;
                }

                h5.blogname {text-transform: uppercase; font-size: 75%;}

                a.post-image {
                    text-indent: -99999px;
                    display: block;
                    width: 100%;
                    height: 180px;
                    margin-bottom: 5px;
                    background-repeat: no-repeat;
                    background-position: center center;
                    background-color: #ccc;
                }
            </style>
            <div class="bdn-blogs-widget-header">
                <a href="http://bangordailynews.com/maine-blogs/?utm_campaign=The+Drive&utm_source=sports-widget">
                    <img src="//bangordailynews.com/wp-content/themes/bdn/images/bdnmaine_110.png" width="60"
                         align="left">
                </a>
                <h3>
                    <a href="http://bangordailynews.com/maine-blogs/?utm_campaign=The+Drive&utm_source=sports-widget">
                        Blogs
                    </a>
                </h3>
                <div class="promo-links">
                    <a class="promo-link" href="http://bangordailynews.com/maine-blogs/be-a-bdn-blogger/">Be a BDN
                        blogger</a> |
                    <a class="promo-link" href="http://bangordailynews.com/maine-blogs/">Browse BDN blogs</a>
                </div>
            </div>
            <div class="bdn-blogs-widget-posts">
				<!-- Blogs widget served from memcached --><!-- blogs category: sports -->
            <div id="blogwidget_1" class="blogwidget">

                <h5 class="blogname">
                    <a href="http://pwilcox.bangordailynews.com/?utm_campaign=The+Drive&utm_source=sports-widget"
                       target=_blank title="Actionable strategies for healthy living that are sustainable for a lifetime">
						Inspire Healthy Living                    </a>
                </h5>

				                    <!-- Image from post image -->
                    <a
                            class="post-image"
                            style="background: #ccc url('https://bdn-data.s3.amazonaws.com/blogs.dir/443/files/2018/10/41135251_2091673420897296_1396309072113827840_n-300x300.jpg'); background-position: center center; background-size: cover;"
                            href="http://pwilcox.bangordailynews.com/2018/10/26/home/your-everyday-healthy-actions-inspire-more-people-than-youd-think/?utm_campaign=The+Drive&utm_source=sports-widget"
                            title="Your everyday healthy actions inspire more people than you'd think...">
						Your everyday healthy actions inspire more people than you'd think...                    </a>

				
                <h4 class="blogstory">
                    <a class="blogstory"
                       href="http://pwilcox.bangordailynews.com/2018/10/26/home/your-everyday-healthy-actions-inspire-more-people-than-youd-think/?utm_campaign=The+Drive&utm_source=sports-widget"
                       target=_blank>
						Your everyday healthy actions inspire more people than you'd think...                    </a>
                </h4>
            </div>

		
            <div id="blogwidget_2" class="blogwidget">

                <h5 class="blogname">
                    <a href="http://thedrive.bangordailynews.com/?utm_campaign=The+Drive&utm_source=sports-widget"
                       target=_blank title="Your sports. Your teams. Your show.">
						The Drive                    </a>
                </h5>

				                    <!-- Image from post image -->
                    <a
                            class="post-image"
                            style="background: #ccc url('https://bdn-data.s3.amazonaws.com/blogs.dir/283/files/2015/01/the-drive-square-logo-300x300.png'); background-position: center center; background-size: cover;"
                            href="http://thedrive.bangordailynews.com/2018/10/22/sports/drive-audio-pete-abraham-gives-sox-world-series-preview/?utm_campaign=The+Drive&utm_source=sports-widget"
                            title="Drive Audio: Pete Abraham gives Sox World Series preview">
						Drive Audio: Pete Abraham gives Sox World Series preview                    </a>

				
                <h4 class="blogstory">
                    <a class="blogstory"
                       href="http://thedrive.bangordailynews.com/2018/10/22/sports/drive-audio-pete-abraham-gives-sox-world-series-preview/?utm_campaign=The+Drive&utm_source=sports-widget"
                       target=_blank>
						Drive Audio: Pete Abraham gives Sox World Series preview                    </a>
                </h4>
            </div>

		
            <div id="blogwidget_3" class="blogwidget">

                <h5 class="blogname">
                    <a href="http://upnorthmotorsports.bangordailynews.com/?utm_campaign=The+Drive&utm_source=sports-widget"
                       target=_blank title="People and events in motorsports">
						Up North Motorsports                    </a>
                </h5>

				                    <!-- Image from post image -->
                    <a
                            class="post-image"
                            style="background: #ccc url('https://bdn-data.s3.amazonaws.com/blogs.dir/244/files/2018/10/Team-OCD-Ethan-Rossignol-at-Ashland-ct-2018-300x300.jpg'); background-position: center center; background-size: cover;"
                            href="http://upnorthmotorsports.bangordailynews.com/2018/10/22/home/roar-of-drag-racing-snowmobiles-on-grass-track-a-hit-in-the-county/?utm_campaign=The+Drive&utm_source=sports-widget"
                            title="Roar of drag racing snowmobiles on grass track a hit in the County">
						Roar of drag racing snowmobiles on grass track a hit in the County                    </a>

				
                <h4 class="blogstory">
                    <a class="blogstory"
                       href="http://upnorthmotorsports.bangordailynews.com/2018/10/22/home/roar-of-drag-racing-snowmobiles-on-grass-track-a-hit-in-the-county/?utm_campaign=The+Drive&utm_source=sports-widget"
                       target=_blank>
						Roar of drag racing snowmobiles on grass track a hit in the County                    </a>
                </h4>
            </div>

		
            <div id="blogwidget_4" class="blogwidget">

                <h5 class="blogname">
                    <a href="http://jgrant.bangordailynews.com/?utm_campaign=The+Drive&utm_source=sports-widget"
                       target=_blank title="A journey of fitness and health">
						Swim, Bike &amp; Motivate                     </a>
                </h5>

				                    <!-- Image from post image -->
                    <a
                            class="post-image"
                            style="background: #ccc url('https://bdn-data.s3.amazonaws.com/blogs.dir/466/files/2018/10/Samantha-300x300.jpg'); background-position: center center; background-size: cover;"
                            href="http://jgrant.bangordailynews.com/2018/10/21/home/spot-light-blog-samantha/?utm_campaign=The+Drive&utm_source=sports-widget"
                            title="Spot Light Blog: Samantha">
						Spot Light Blog: Samantha                    </a>

				
                <h4 class="blogstory">
                    <a class="blogstory"
                       href="http://jgrant.bangordailynews.com/2018/10/21/home/spot-light-blog-samantha/?utm_campaign=The+Drive&utm_source=sports-widget"
                       target=_blank>
						Spot Light Blog: Samantha                    </a>
                </h4>
            </div>

		
            <div id="blogwidget_5" class="blogwidget">

                <h5 class="blogname">
                    <a href="http://offtherim.bangordailynews.com/?utm_campaign=The+Drive&utm_source=sports-widget"
                       target=_blank title="Covering all aspects of high school, prep, college and pro basketball.">
						Off the Rim                    </a>
                </h5>

				
                <h4 class="blogstory">
                    <a class="blogstory"
                       href="http://offtherim.bangordailynews.com/2018/10/17/high-school/umaine-men-basketball-ranked-319th-of-352-d-1-teams/?utm_campaign=The+Drive&utm_source=sports-widget"
                       target=_blank>
						UMaine men basketball ranked 319th of 352 D-1 teams                    </a>
                </h4>
            </div>

		            </div>

        </div><!-- /.bdn-blogs-widget -->

		<!-- Blogs widget took 0.005280 seconds to load. --><aside id="twitter_timeline-2" class="widget widget_twitter_timeline"><h3 class="widget-title">Follow The Drive Team on Twitter</h3><a class="twitter-timeline" data-height="400" data-theme="light" data-link-color="#f96e5b" data-border-color="#e8e8e8" data-tweet-limit="15" data-lang="EN" data-partner="jetpack" data-widget-id="">My Tweets</a></aside>
		<div class="adSpot widget" style="min-height:270px;">
		    <div id="bdnads-blogs-bottom-300x250">
			 <script type="text/javascript">
			      googletag.cmd.push(function() {
				    googletag.display("bdnads-blogs-bottom-300x250");
			       });
			  </script>
		    </div>
		</div>
	    </div><!-- .widget-area -->

	</div><!-- .sidebar-inner -->
    </div><!-- #tertiary -->
	
	

		</div><!-- #main -->
		<footer id="colophon" class="site-footer" role="contentinfo">
				<div id="secondary" class="sidebar-container" role="complementary">
		<div class="widget-area">
			<aside id="search-4" class="widget widget_search"><h3 class="widget-title">Search</h3><form role="search" method="get" id="searchform" class="search-form" action="https://thedrive.bangordailynews.com">
	<label>
		<span class="screen-reader-text" for="s">Search for:</span>
		<input type="search" class="search-field" value="" name="s" placeholder="Search ..." title="Search for:">
	</label>
	<input type="submit" class="search-submit" id="searchsubmit" value="Search">
</form></aside><aside id="text-3" class="widget widget_text"><h3 class="widget-title">Contact</h3>			<div class="textwidget"><div role="form" class="wpcf7" id="wpcf7-f3-o1" dir="ltr">
<div class="screen-reader-response"></div>
<form action="/2018/10/28/sports/sterling-notes-nfl-week-8/#wpcf7-f3-o1" method="post" class="wpcf7-form" novalidate="novalidate">
<div style="display: none;">
<input type="hidden" name="_wpcf7" value="3" />
<input type="hidden" name="_wpcf7_version" value="4.7" />
<input type="hidden" name="_wpcf7_locale" value="" />
<input type="hidden" name="_wpcf7_unit_tag" value="wpcf7-f3-o1" />
<input type="hidden" name="_wpnonce" value="f1edd30378" />
</div>
<p>Your Name (required)<br />
    <span class="wpcf7-form-control-wrap your-name"><input type="text" name="your-name" value="" size="40" class="wpcf7-form-control wpcf7-text wpcf7-validates-as-required" aria-required="true" aria-invalid="false" /></span> </p>
<p>Your Email (required)<br />
    <span class="wpcf7-form-control-wrap your-email"><input type="email" name="your-email" value="" size="40" class="wpcf7-form-control wpcf7-text wpcf7-email wpcf7-validates-as-required wpcf7-validates-as-email" aria-required="true" aria-invalid="false" /></span> </p>
<p>Subject<br />
    <span class="wpcf7-form-control-wrap your-subject"><input type="text" name="your-subject" value="" size="40" class="wpcf7-form-control wpcf7-text" aria-invalid="false" /></span> </p>
<p>Your Message<br />
    <span class="wpcf7-form-control-wrap your-message"><textarea name="your-message" cols="40" rows="10" class="wpcf7-form-control wpcf7-textarea" aria-invalid="false"></textarea></span> </p>
<p><input type="submit" value="Send" class="wpcf7-form-control wpcf7-submit" /></p>
<div class="wpcf7-response-output wpcf7-display-none"></div></form></div></div>
		</aside><aside id="blog_subscription-3" class="widget jetpack_subscription_widget"><h3 class="widget-title">Subscribe to Blog via Email</h3>
			<form action="#" method="post" accept-charset="utf-8" id="subscribe-blog-blog_subscription-3">
				<div id="subscribe-text"><p>Enter your email address to subscribe to this blog and receive notifications of new posts by email.</p>
</div>					<p id="subscribe-email">
						<label id="jetpack-subscribe-label" for="subscribe-field-blog_subscription-3">
							Email Address						</label>
						<input type="email" name="email" required="required" class="required" value="" id="subscribe-field-blog_subscription-3" placeholder="Email Address" />
					</p>

					<p id="subscribe-submit">
						<input type="hidden" name="action" value="subscribe" />
						<input type="hidden" name="source" value="https://thedrive.bangordailynews.com/2018/10/28/sports/sterling-notes-nfl-week-8/" />
						<input type="hidden" name="sub-type" value="widget" />
						<input type="hidden" name="redirect_fragment" value="blog_subscription-3" />
												<input type="submit" value="Subscribe" name="jetpack_subscriptions_widget" />
					</p>
							</form>

			<script>
			/*
			Custom functionality for safari and IE
			 */
			(function( d ) {
				// In case the placeholder functionality is available we remove labels
				if ( ( 'placeholder' in d.createElement( 'input' ) ) ) {
					var label = d.querySelector( 'label[for=subscribe-field-blog_subscription-3]' );
						label.style.clip 	 = 'rect(1px, 1px, 1px, 1px)';
						label.style.position = 'absolute';
						label.style.height   = '1px';
						label.style.width    = '1px';
						label.style.overflow = 'hidden';
				}

				// Make sure the email value is filled in before allowing submit
				var form = d.getElementById('subscribe-blog-blog_subscription-3'),
					input = d.getElementById('subscribe-field-blog_subscription-3'),
					handler = function( event ) {
						if ( '' === input.value ) {
							input.focus();

							if ( event.preventDefault ){
								event.preventDefault();
							}

							return false;
						}
					};

				if ( window.addEventListener ) {
					form.addEventListener( 'submit', handler, false );
				} else {
					form.attachEvent( 'onsubmit', handler );
				}
			})( document );
			</script>
				
</aside><aside id="rss_links-3" class="widget widget_rss_links"><h3 class="widget-title">Subscribe via RSS</h3><p><a target="_self" href="https://thedrive.bangordailynews.com/feed/" title="Subscribe to Posts"><img src="https://thedrive.bangordailynews.com/wp-content/plugins/jetpack/images/rss/orange-large.png" alt="RSS Feed" /></a>&nbsp;<a target="_self" href="https://thedrive.bangordailynews.com/feed/" title="Subscribe to Posts">RSS - Posts</a></p>
</aside><aside id="archives-4" class="widget widget_archive"><h3 class="widget-title">Archives</h3>		<ul>
			<li><a href='https://thedrive.bangordailynews.com/2018/10/'>October 2018</a>&nbsp;(14)</li>
	<li><a href='https://thedrive.bangordailynews.com/2018/09/'>September 2018</a>&nbsp;(12)</li>
	<li><a href='https://thedrive.bangordailynews.com/2018/08/'>August 2018</a>&nbsp;(9)</li>
	<li><a href='https://thedrive.bangordailynews.com/2018/07/'>July 2018</a>&nbsp;(8)</li>
	<li><a href='https://thedrive.bangordailynews.com/2018/06/'>June 2018</a>&nbsp;(13)</li>
	<li><a href='https://thedrive.bangordailynews.com/2018/05/'>May 2018</a>&nbsp;(15)</li>
	<li><a href='https://thedrive.bangordailynews.com/2018/04/'>April 2018</a>&nbsp;(15)</li>
	<li><a href='https://thedrive.bangordailynews.com/2018/03/'>March 2018</a>&nbsp;(24)</li>
	<li><a href='https://thedrive.bangordailynews.com/2018/02/'>February 2018</a>&nbsp;(20)</li>
	<li><a href='https://thedrive.bangordailynews.com/2018/01/'>January 2018</a>&nbsp;(31)</li>
	<li><a href='https://thedrive.bangordailynews.com/2017/12/'>December 2017</a>&nbsp;(23)</li>
	<li><a href='https://thedrive.bangordailynews.com/2017/11/'>November 2017</a>&nbsp;(25)</li>
	<li><a href='https://thedrive.bangordailynews.com/2017/10/'>October 2017</a>&nbsp;(25)</li>
	<li><a href='https://thedrive.bangordailynews.com/2017/09/'>September 2017</a>&nbsp;(19)</li>
	<li><a href='https://thedrive.bangordailynews.com/2017/08/'>August 2017</a>&nbsp;(23)</li>
	<li><a href='https://thedrive.bangordailynews.com/2017/07/'>July 2017</a>&nbsp;(19)</li>
	<li><a href='https://thedrive.bangordailynews.com/2017/06/'>June 2017</a>&nbsp;(22)</li>
	<li><a href='https://thedrive.bangordailynews.com/2017/05/'>May 2017</a>&nbsp;(29)</li>
	<li><a href='https://thedrive.bangordailynews.com/2017/04/'>April 2017</a>&nbsp;(23)</li>
	<li><a href='https://thedrive.bangordailynews.com/2017/03/'>March 2017</a>&nbsp;(28)</li>
	<li><a href='https://thedrive.bangordailynews.com/2017/02/'>February 2017</a>&nbsp;(25)</li>
	<li><a href='https://thedrive.bangordailynews.com/2017/01/'>January 2017</a>&nbsp;(43)</li>
	<li><a href='https://thedrive.bangordailynews.com/2016/12/'>December 2016</a>&nbsp;(44)</li>
	<li><a href='https://thedrive.bangordailynews.com/2016/11/'>November 2016</a>&nbsp;(37)</li>
	<li><a href='https://thedrive.bangordailynews.com/2016/10/'>October 2016</a>&nbsp;(19)</li>
	<li><a href='https://thedrive.bangordailynews.com/2016/09/'>September 2016</a>&nbsp;(5)</li>
	<li><a href='https://thedrive.bangordailynews.com/2016/08/'>August 2016</a>&nbsp;(16)</li>
	<li><a href='https://thedrive.bangordailynews.com/2016/07/'>July 2016</a>&nbsp;(14)</li>
	<li><a href='https://thedrive.bangordailynews.com/2016/06/'>June 2016</a>&nbsp;(11)</li>
	<li><a href='https://thedrive.bangordailynews.com/2016/05/'>May 2016</a>&nbsp;(17)</li>
	<li><a href='https://thedrive.bangordailynews.com/2016/04/'>April 2016</a>&nbsp;(20)</li>
	<li><a href='https://thedrive.bangordailynews.com/2016/03/'>March 2016</a>&nbsp;(1)</li>
		</ul>
		</aside>		</div><!-- .widget-area -->
	</div><!-- #secondary -->

			<div class="site-info">
                            <a href="http://bangordailynews.com/maine-blogs/?utm_source=The+Drive&utm_medium=footer">
                                <img src="https://thedrive.bangordailynews.com/wp-content/themes/bdnblog2013/images/BDN_Square.jpg" width="32" />
                                The Drive is a member of the BDN Maine Blog network.
                            </a>
			</div><!-- .site-info -->
			
			<!--Desktop only-->
			<div id="footer">
			    <div id="box-wrap">
				<div id="box1">
				    <h1 class="headline">Bangor Daily News</h1>
				    <ul class="sitemap">
					<li><a href="http://archive.bangordailynews.com/">Archives</a></li>
					<li><a href="http://bangordailynews.com/">News</a></li>
					<li><a href="http://bangordailynews.com/business/">Business</a></li>
					<li><a href="http://bangordailynews.com/sports/">Sports</a></li>
					<li><a href="http://bangordailynews.com/outdoors/">Outdoors</a></li>
					<li><a href="http://bangordailynews.com/homestead/">Homestead</a></li>
					<li><a href="http://bangordailynews.com/link/tv-listings/">TV Listings</a></li>
					<li><a href="http://obituaries.bangordailynews.com/">Obituaries</a></li>
					<li><a href="http://bangordailynews.com/events/">Things to Do</a></li>
					<li><a href="http://bangordailynews.com/special-sections/">Custom Publications</a></li>
					<li><a href="http://marketplace.bangordailynews.com/?post_type=coupon">Coupons</a></li>
					<li><a href="http://bangordailynews.com/weather/">Weather</a></li>
					<li><a href="http://bangordailynews.com/closings/">Storm Cancellations</a></li>
				    </ul>
				</div><!-- #box1 -->
				<div id="box2">
				    <h1 class="headline">About Us</h1>
				    <ul class="sitemap">
					<li><a href="http://bangordailynews.com/about/">BDN History</a></li>
					<li><a href="http://external.bangordailynews.com/bdn-anniversary/">BDN 120 Years</a></li>
					<li><a href="http://bangordailynews.com/contact">Contact Us</a></li>
					<li><a href="http://store.bangordailynews.com/">Purchase Photos</a></li>
					<li><a href="http://nie.bangordailynews.com/">Newspapers in Education</a></li>
					<li><a href="http://bangordailynews.com/terms-of-service/">Terms of Service</a></li>
					<li><a href="http://bangordailynews.com/privacy/">Privacy Policy</a></li>
				    </ul>
				    <h1 class="headline" style="margin-top: 15px;">Subscribe</h1>
				    <ul class="sitemap">
					<li><a href="http://bangordailynews.com/subscribe/">Bangor Daily News Subscriptions</a></li>
					<li><a href="http://bangordailynews.com/staff/circulation/">Manage Your Subscription</a></li>
					<li><a href="http://bangordailynews.com/newsletters/">Email Updates</a></li>
					<li><a href="http://bangordailynews.com/feed/">RSS</a></li>
				    </ul>
				</div><!-- #box2 -->
				<div id="box3">
				    <h1 class="headline">Sales and Marketing</h1>
				    <ul class="sitemap">
					<li><a href="http://bangordailynews.com/staff/advertising/classifieds/">Classifieds</a></li>
					<li><a href="http://bangordailynews.com/staff/advertising/">Print and Online Advertising</a></li>
					<li><a href="http://bangordailynews.com/staff/advertising/special-sections/">Custom Publications and The Weekly</a></li>
					<li><a href="http://bangordailynews.com/staff/advertising/">Advertising Staff Directory</a></li>
					<li><a href="http://creativeservices.bangordailynews.com/guide-to-sending-files/">Creative Services-Guide to Sending Files</a></li>
				    </ul>
				</div><!-- #box3 -->
				<div id="box4">
				    <h1 class="headline">On Facebook</h1>
                    <ul class="sitemap">
                        <li><a href="http://www.facebook.com/bangordailynews" title="The Bangor Daily News on Facebook">The Bangor Daily News</a></li>
                        <li><a href="http://www.facebook.com/bdnmainemidcoast" title="BDN Midcoast on Facebook">Midcoast</a></li>
                        <li><a href="http://www.facebook.com/bdnmaineportland" title="BDN Portland on Facebook">Portland</a></li>
                        <li><a href="http://www.facebook.com/bdnmainearoostook" title="BDN Aroostook on Facebook">Aroostook</a></li>
                        <li><a href="http://www.facebook.com/bdnmainedowneast" title="BDN Midcoast on Facebook">Downeast</a></li>
                        <li><a href="http://www.facebook.com/bdnmainehancock" title="BDN Hancock on Facebook">Hancock</a></li>
                        <li><a href="http://www.facebook.com/pages/BDN-Katahdin-and-Lincoln-Lakes-Region-News/139993822727247" title="BDN Katahdin and Lincoln Lakes Region on Facebook">Katahdin and Lincoln Lakes Region</a></li>
                        <hr />
                        <li><a href="http://www.facebook.com/BDNFoodForThought" title="BDN Food on Facebook">Food</a></li>
                        <li><a href="https://www.facebook.com/bdnmaineoutdoors" title="BDN Outdoors on Facebook">Outdoors</a></li>
                        <li><a href="https://www.facebook.com/BDNMaineFamilies" title="BDN Maine Families on Facebook">Maine Families</a></li>
                        <li><a href="https://www.facebook.com/BDNBlogs" title="BDN Blogs on Facebook">BDN Blogs</a></li>
                        <hr />
                        <li><a href="https://www.facebook.com/pages/BDN-Editorial-Opinion/107406425993156" title="BDN Editorial and Opinion on Facebook">Editorial and Opinion</a></li>
                        <hr />
                        <li><a href="https://www.facebook.com/bdnmainesports" title="BDN Maine Sports on Facebook">Maine Sports</a></li>
                        <li><a href="https://www.facebook.com/bdnhssports" title="BDN High School Sports on Facebook">High School Sports</a></li>
                    </ul>
                    <h1 class="headline">On Twitter</h1>
                    <ul class="sitemap">
                        <li><a href="http://www.twitter.com/bangordailynews" title="The Bangor Daily News on Twitter">@bangordailynews</a></li>
                        <li><a href="http://www.twitter.com/bdnpolitics" title="The Bangor Daily News on Twitter">@bdnpolitics</a></li>
                        <li><a href="http://www.twitter.com/bdnmaineblogs" title="The Bangor Daily News Blogs on Twitter">@bdnmaineblogs</a></li>
                        <li><a href="http://www.twitter.com/bdnmainefocus" title="The Bangor Daily News Maine Focus on Twitter">@bdnmainefocus</a></li>
                    </ul>
				</div><!-- #box4 -->
			    </div><!--#box-wrap -->
			</div>
			
		</footer><!-- #colophon -->
	</div><!-- #page -->

		<div style="display:none">
	</div>
<script type='text/javascript' src='https://thedrive.bangordailynews.com/wp-content/plugins/contact-form-7/includes/js/jquery.form.min.js?ver=3.51.0-2014.06.20'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var _wpcf7 = {"recaptcha":{"messages":{"empty":"Please verify that you are not a robot."}},"cached":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://thedrive.bangordailynews.com/wp-content/plugins/contact-form-7/includes/js/scripts.js?ver=4.7'></script>
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201843'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var emailL10n = {"ajax_url":"https:\/\/thedrive.bangordailynews.com\/wp-admin\/admin-ajax.php","max_allowed":"5","text_error":"The Following Error Occurs:","text_name_invalid":"- Your Name is empty\/invalid","text_email_invalid":"- Your Email is empty\/invalid","text_remarks_invalid":"- Your Remarks is invalid","text_friend_names_empty":"- Friend Name(s) is empty","text_friend_name_invalid":"- Friend Name is empty\/invalid: ","text_max_friend_names_allowed":"- Maximum 5 Friend Names allowed","text_friend_emails_empty":"- Friend Email(s) is empty","text_friend_email_invalid":"- Friend Email is invalid: ","text_max_friend_emails_allowed":"- Maximum 5 Friend Emails allowed","text_friends_tally":"- Friend Name(s) count does not tally with Friend Email(s) count","text_image_verify_empty":"- Image Verification is empty"};
/* ]]> */
</script>
<script type='text/javascript' src='https://thedrive.bangordailynews.com/wp-content/plugins/wp-email/email-js.js?ver=2.67.5'></script>
<script type='text/javascript' src='https://secure.gravatar.com/js/gprofiles.js?ver=2018Octaa'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPGroHo = {"my_hash":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://thedrive.bangordailynews.com/wp-content/plugins/jetpack/modules/wpgroho.js?ver=4.9.6'></script>
<script type='text/javascript' src='https://thedrive.bangordailynews.com/wp-includes/js/imagesloaded.min.js?ver=3.2.0'></script>
<script type='text/javascript' src='https://thedrive.bangordailynews.com/wp-includes/js/masonry.min.js?ver=3.3.2'></script>
<script type='text/javascript' src='https://thedrive.bangordailynews.com/wp-includes/js/jquery/jquery.masonry.min.js?ver=3.1.2b'></script>
<script type='text/javascript' src='https://thedrive.bangordailynews.com/wp-content/themes/bdnblog2013/js/functions.js?ver=2013-07-18'></script>
<script type='text/javascript' src='https://thedrive.bangordailynews.com/wp-content/themes/bdnblog2013/js/out-of-page-ad.js?ver=2018-07-18'></script>
<script type='text/javascript' src='https://thedrive.bangordailynews.com/wp-content/plugins/jetpack/_inc/build/twitter-timeline.min.js?ver=4.0.0'></script>
<script type='text/javascript' src='https://thedrive.bangordailynews.com/wp-content/mu-plugins/js/submitevent.js?ver=2'></script>
<script type='text/javascript' src='https://thedrive.bangordailynews.com/wp-includes/js/wp-embed.min.js?ver=4.9.6'></script>
<script type='text/javascript' src='https://stats.wp.com/e-201843.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:5.9',blog:'83392572',post:'2352',tz:'-4',srv:'thedrive.bangordailynews.com'} ]);
	_stq.push([ 'clickTrackerInit', '83392572', '2352' ]);
</script>
</body>
</html>
